Videos streaming images jeux et buzz
Connexion






Perdu le mot de passe ?

Inscrivez-vous maintenant !
Menu Principal
Communauté


(1) 2 »


Koreus
Bug en HTTPS
 2  #1
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
Si vous avez des bugs ou des comportements étranges en utilisant la version HTTPS du site, vous pouvez les signaler ici.

Contribution le : 27/01/2017 12:13
_________________
Signaler

mahnmut
 0  #2
Je suis accro
Inscrit: 08/05/2014 11:48
Post(s): 1904
Karma: 573
Je vais faire le tour pour noter tous ce que je vois.

Sur tes certificats je vois pas de problèmes pour le moment mais j'en ai sur l’intégration de certaine images :

Par exemple : ici
Les images de puu.sh sont intégré en http et non https

Dans ce thread aussi : Symbole inconnu mais pour d'autre sources.

Contribution le : 27/01/2017 16:21
Signaler

Naarob
 0  #3
Je m'installe
Inscrit: 26/07/2016 19:32
Post(s): 106
Karma: 53
Sur Qualys j'ai ça :

HTTP Requests
1 https://www.koreus.com/ (HTTP/1.1 301 Moved Permanently)
1
Server nginx/1.10.2
Date Fri, 27 Jan 2017 16:18:19 GMT
Content-Type text/html; charset=UTF-8
Content-Length 0
Connection close
Status 301 Moved Permanently
Location //www.koreus.com/modules/news/
X-Cache-Status HIT
Cache-Control no-cache
2 https://www.koreus.com//www.koreus.com/modules/news/ (HTTP/1.1 404 Not Found)
2
Server nginx/1.10.2
Date Fri, 27 Jan 2017 16:18:19 GMT
Content-Type text/html
Content-Length 5299
Connection close
Last-Modified Fri, 10 Oct 2014 15:18:56 GMT
ETag "14b3-50513114ff131"

ssllab qualys

Contribution le : 27/01/2017 18:10
Signaler

Koreus
 0  #4
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
@mahnmut

Je ne peux rien faire pour les images dans les messages ajoutées par les utilisateur. Je pourrais forcer le HTTPS mais tous les sites d'hébergement ne le gèrent pas encore

@Naarob Ah ? Je vais regarder ça

Edit : J'ai corrigé normalement

Contribution le : 27/01/2017 18:19
_________________
Signaler

mahnmut
 0  #5
Je suis accro
Inscrit: 08/05/2014 11:48
Post(s): 1904
Karma: 573
@Koreus Oui je sais mais pour l'utilisateur ça déroute un peu.
Pas moyen avec un genre de proxy ou de cache pour ceux ne supportant pas https ?

Pas top mais j'ai jamais eu à résoudre ce genre de problème.

Contribution le : 27/01/2017 18:55
Signaler

Skity
 0  #6
Je masterise !
Inscrit: 29/12/2013 23:48
Post(s): 2025
Karma: 521
Quand on est sur la page principale (https://www.koreus.com) et que l'on clique sur "voir tous les articles":



Ca fait retourner en HTTP tout court

--> Même problème avec "Voir son compte" sur la colonne de gauche (enfin cette fois le 'a href' est bien en https mais ça redirige derrière en http)

----------------------------------------------------
----------------------------------------------------
----------------------------------------------------


Le bouton "signaler" n'est pas en HTTPS, il n'est donc pas chargé.
URL: http://static.koreus.cdn.li/images/flag_red.gif

Symptôme:




----------------------------------------------------
----------------------------------------------------
----------------------------------------------------

Problème au niveau de l'intégration des vidéos (ici Youtube)

Exemple: https://www.koreus.com/modules/newbb/topic165792-20.html#forumpost2371192

Le remplacement en https au niveau de l'URL de l'embed fonctionne pour Youtube.

Exemple: https://www.youtube.com/embed/fPwhI5A7g-M

Contribution le : 28/01/2017 18:36
Signaler

Koreus
 0  #7
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
@Skity Normalement j'ai tout corrigé

Pour le bouton "signaler", Poum45 m'avait déjà signalé l'erreur mais je ne comprends pas car de mon côté l'URL est correct. Y un truc qui m'échappe

Contribution le : 28/01/2017 19:29
_________________
Signaler

Skity
 0  #8
Je masterise !
Inscrit: 29/12/2013 23:48
Post(s): 2025
Karma: 521
Citation :

@Koreus a écrit:
@Skity Normalement j'ai tout corrigé

Pour le bouton "signaler", Poum45 m'avait déjà signalé l'erreur mais je ne comprends pas car de mon côté l'URL est correct. Y un truc qui m'échappe


Liste de problèmes en HTTPS répertoriés:

* Image drapeau "signaler" ❌
--> URL: http://static.koreus.cdn.li/images/flag_red.gif
--> Le domaine ne semble pas être propagé: https://www.whatsmydns.net/#A/static.koreus.cdn.li
--> static.koreus.cdn.li CNAME de static.koreus.cdn.li.web.cdn.anycast.me qui ne résoud pas: https://www.whatsmydns.net/#A/static.koreus.cdn.li.web.cdn.anycast.me

* Problème avec intégration Youtube ❌
--> Toujours le cas

* Manques au niveau du Wildcard du certificat ❌
--> Il manque "koreus.com" tout court.
--> https://www.koreus.com fonctionne, mais https://koreus.com renvoie une alerte de certificat
--> Le wildcard est fait ainsi "*.koreus.com", peut être mettre plutôt "*koreus.com" sans le point ?


== De Mahnmut

* Les liens du logo koreus, Article et forum renvoi sur la version http et non https (❓ en attente de correction du reste ❓)
-> Exemple: https://www.koreus.com/video/vtt-appartement-leo-nobile.html





---------- Historique
* Le voir les articles ✔

* Voir son compte (corrigé ✔️)

--> Redirige vers "https://www.koreus.com/http//www.koreus.com/membre/[accountName] => Not Found
--> :idea: Ne fonctionne plus non plus en HTTP

----------


Voili voilou 🙂

Pour info: J'utilise "classiquement" Firefox. Les tests sont fait en navigation privée sur Chrome à jour 🙂

Contribution le : 28/01/2017 19:56
Signaler

mahnmut
 0  #9
Je suis accro
Inscrit: 08/05/2014 11:48
Post(s): 1904
Karma: 573
Quand on est sur une page article genre : https://www.koreus.com/video/vtt-appartement-leo-nobile.html

Les liens du logo koreus, Article et forum renvoi sur la version http et non https.

Contribution le : 28/01/2017 22:36
Signaler

Koreus
 0  #10
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
@Skity Merci, je regarde ça demain

@mahnmut Oui c'est normal, pour l'instant, je préfère rediriger les utilisateurs vers la version http du site. En attendant de tout corriger 🙂

Contribution le : 29/01/2017 00:00
_________________
Signaler

CrazyCow
 0  #11
Je poste trop
Inscrit: 29/07/2008 00:26
Post(s): 13122
Karma: 14741
Sur tout le forum j'ai ça qui empêche le cadenas vert :


A Parser-blocking, cross-origin script, http://cas.criteo.com/delivery/ajs.php?ptv=13&zoneid=517700&cb=40434603876&…tfr=1&loc=http%3A%2F%2Fwww.koreus.com%2Fmodules%2Fnewbb%2Ftopic166334.html, is invoked via document.write. 
This may be blocked by the browser if the device has poor network connectivity. See https://www.chromestatus.com/feature/5718547946799104 for more details.
b.loadScriptSync @ publishertag.js:1
b.eval @ publishertag.js:1
b.evalEvents @ publishertag.js:1
b.push @ publishertag.js:1
b @ publishertag.js:1
(anonymous) @ topic166334.html:142


En gros Criteo (encart publicitaire ?) est chargé en HTTP. Le HTTPS peut fonctionner sur cet URL.

Contribution le : 03/02/2017 11:37
_________________
Je crois que je vais faire une vidéo qui montre comment manger un kiwi...
...plume par plume
Signaler

Alex333
 0  #12
Help Desk
Inscrit: 07/07/2008 12:56
Post(s): 25188
Karma: 12297
Si je balaye tous les liens du menu Koreus (a gauche), je vois que certains liens renvoient ok vers le site avec url "https://www.koreus.com etc", mais pour certains liens, le signe "(i)" s'affiche et la mention "Secure" avant l'url n'y est plus.
Je sais pas si c'est important

C'est le cas pour les liens :
- Voir son compte
- Mes amis
- Mes favoris
- Wiki (qui renvoie vers http://www.koreus.com/modules/news/)
- Rejoindre le chat (qui renvoie vers https://wiki.koreus.com/Salon_de_discussion, erreur deja rapportée dans le ticket Connexion impossible au Wiki Koreus
- TeamSpeak
- Présentation (qui pourtant marchait y a 2 secondes ?!)

Ouai. Bon enfin je vois la que selon sur quelle page du site je vais, si je re-clique sur le logo ca me renvoie soit vers le site "Secure" en https, ou vers le site non secure en http. Et il semble que selon, les liens du menu renvoient vers la version secure https ou pas.

Contribution le : 03/02/2017 18:20
Signaler

CrazyCow
 0  #13
Je poste trop
Inscrit: 29/07/2008 00:26
Post(s): 13122
Karma: 14741
@Koreus Tu ne redoutes pas un problème de Duplicate Content en autorisant les pages en HTTP et HTTPS ?

Contribution le : 04/02/2017 14:48
_________________
Je crois que je vais faire une vidéo qui montre comment manger un kiwi...
...plume par plume
Signaler

Koreus
 0  #14
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
@CrazyCow Normalement non avec le link canonical mais de toute façon c'est temporaire. Je devrais tout basculer en https assez rapidement

Contribution le : 04/02/2017 16:08
_________________
Signaler

CrazyCow
 0  #15
Je poste trop
Inscrit: 29/07/2008 00:26
Post(s): 13122
Karma: 14741
@Koreus Ah oui exact, je n'avais pas vu la balise.

Contribution le : 04/02/2017 16:18
_________________
Je crois que je vais faire une vidéo qui montre comment manger un kiwi...
...plume par plume
Signaler

Koreus
 1  #16
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
Le site est maintenant exclusivement en HTTPS.

Donc si vous rencontrez des problèmes, n'hésitez pas à me les faire part.

Contribution le : 06/02/2017 15:05
_________________
Signaler

Insert
 0  #17
J'aime glander ici
Inscrit: 06/07/2010 18:11
Post(s): 7721
Karma: 2193
Citation :

@Koreus a écrit:
Le site est maintenant exclusivement en HTTPS.

Donc si vous rencontrez des problèmes, n'hésitez pas à me les faire part.

J'imagine que ça vient de ça :
j'étais connecté sur le site, et j'ai voulu commenter.

Un bandeau gris apparait sans erreur d'indiquée, je suis censé rafraichir, mais rien ne se passe, la page reste blanche

(l'url était un truc du genre session confirm)
Et si je voulais revenir sur le site, j'étais toujours connecté. Impossible de me déconnecter pour les mêmes raisons.
Je déco, ça me met ce même bandeau, puis plus rien. Et je reste connecté.

J'ai essayé de me connecter puis de me déco en navigation privée, ça a fonctionné, mais le problème persistait dans ma fenêtre classique.
Du coup, j'ai supprimé les cookies.

Mais j'imagine que je ne suis pas le seul à qui cela arrive, faudrait peut-être leur expliquer la maneuvre 😃

Contribution le : 06/02/2017 15:16
_________________

_______________________En repensant au temps où j'avais le temps de venir ici...
Signaler

Poum45
 0  #18
Koreus Addict
Inscrit: 03/12/2007 23:03
Post(s): 59596
Karma: 4214


En cliquant, il me dit que la connexion n'est pas sécurisée.



Au cas où, j'ai désactivé la protection de FF pour ce site et c'est toujours la même chose.

Contribution le : 18/02/2017 14:58
_________________
Les mouches m'agacent mais Le Croco c'est par là
Signaler

CureSafaia
 1  #19
Je m'installe
Inscrit: 04/05/2014 14:06
Post(s): 204
Citation :

@Poum45 a écrit:


En cliquant, il me dit que la connexion n'est pas sécurisée.



Au cas où, j'ai désactivé la protection de FF pour ce site et c'est toujours la même chose.


Firefox indique que la page contient des éléments non sécurisés sur une page sécurisée, ça vient en fait des images dans certaines signatures qui sont en HTTP ^^

Sinon pour la protection c'est encore autre chose, c'est lié à la pub, faudra voir à koreus mais ça doit pas être important

https://developer.mozilla.org/fr/Firefox/Privacy/protection_contre_le_pistage

Contribution le : 18/02/2017 15:13
Signaler

Koreus
 0  #20
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 63384
Karma: 25710
Oui je ne peux pas faire grand chose contre ça, ou alors interdire carrément l'intégration d'image non HTTPS mais ça serait un peu brutal 🙂

Contribution le : 19/02/2017 10:32
_________________
Signaler


 Haut   Précédent   Suivant
(1) 2 »






Si vous êtes l'auteur d'un élément de ce site, vous pouvez si vous le souhaitez, le modifier ou le supprimer
Merci de me contacter par mail. Déclaré à la CNIL N°1031721.