Videos streaming images jeux et buzz
Connexion






Perdu le mot de passe ?

Inscrivez-vous maintenant !
Menu Principal
Communauté




MrGii
Pour les balèzes en Excel
 1  #1
Je suis accro
Inscrit: 18/04/2012 13:13
Post(s): 565
Karma: 270
Salut !
Je bloque sur une fonction dans excel.
Somme.si et sa soeur somme.si.ens

Pour faire simple, j ai une liste d'utilisateurs et le temps passé sur une tache.

Greg 1
Valentin 3
Beranger 4
Greg 6
? 4
Valentin 2
Tous 3

mon somme.si me permet d'additionner les valeurs de ma 2e colonne si la condition est vraie (ligne=greg, alors j'additionne) :
Greg 7 (1+6)
Valentin 5 (3+2)
Beranger 4

Mon probleme, et ce TOUJOURS en utilisant une des 2 fonctions (si possible) j'aimerais additionner tout ce qui n est pas Greg, Valentin ou Beranger. dans mon cas :
Autres 7 (4 de ? et 3 de tous)

Alors oui.. j ai déja fait le total des heures moins la sommes des 3 critères. Mais c est pas ce que je veux

Somme.si.ens ne fonctionne s'il y a plusieurs zones de criteres. Il ne me laisse pas faire plusieurs conditions sur une zone identique.

Z'auriez pas une idée ? (et non.. je veux pas me lancer dans une marco VBA...)


Arci d avance !

G

Contribution le : 18/08/2017 14:05
Signaler

mikelemerle
 0  #2
Je masterise !
Inscrit: 08/11/2012 15:06
Post(s): 2536
Karma: 966
Si c'est toujours "?" et "Tous" alors place les en critère !!!
Y'a peut être un truc qui m’échappe...

Contribution le : 18/08/2017 14:21
Signaler

-Flo-
 1  #3
Kollossal
Inscrit: 08/01/2005 13:41
Post(s): 12260
Karma: 5296
Citation :

@MrGii a écrit:
Somme.si.ens ne fonctionne s'il y a plusieurs zones de criteres. Il ne me laisse pas faire plusieurs conditions sur une zone identique.


Normalement si, je ne sais pas comment tu es arrivé à cette conclusion. Cette formule :

=SOMME.SI.ENS(B1:B7;A1:A7;"<>Greg";A1:A7;"<>Valentin";A1:A7;"<>Beranger")

Me donne bien 7 en reproduisant ton tableau en A1:B7.

Contribution le : 18/08/2017 14:31
_________________
Signaler

MrGii
 0  #4
Je suis accro
Inscrit: 18/04/2012 13:13
Post(s): 565
Karma: 270
Citation :

@-Flo- a écrit:
Citation :

@MrGii a écrit:
Somme.si.ens ne fonctionne s'il y a plusieurs zones de criteres. Il ne me laisse pas faire plusieurs conditions sur une zone identique.


Normalement si, je ne sais pas comment tu es arrivé à cette conclusion. Cette formule :

=SOMME.SI.ENS(B1:B7;A1:A7;"<>Greg";A1:A7;"<>Valentin";A1:A7;"<>Beranger")

Me donne bien 7 en reproduisant ton tableau en A1:B7.


Tout d'abord MERCI !

Mais j y comprends rien... je l ai faite 1000 fois et exactement comme tu l as écrite.... et à chaque fois ça me disais #VALEUR!

Bref... Résolu !

Contribution le : 18/08/2017 15:06
Signaler

TexasRanger
 1  #5
Je suis accro
Inscrit: 24/12/2011 19:11
Post(s): 1215
Karma: 443
Mais question très simple : ce n'est pas plus simple de faire la somme totale - les sous somme que tu as calculés individuellement ?
Ensuite, pour ton "j'y comprend rien" conseille :
Sur les fonction un peu compliqué (je trouves que SOMME.SI.ENS en fait partie) la première fois, ne l'utilise pas directement. A gauche de là où tu rentre la formule il y a le petit bouton "f_x" qui te permet d'aller remplir les différents champs des fonctions sans avoir à faire attention à comment tu écris la formule. Je trouve ça pratique pour découvrir l'utilisation de tel fonction

Contribution le : 18/08/2017 16:00
Signaler


 Haut   Précédent   Suivant






Si vous êtes l'auteur d'un élément de ce site, vous pouvez si vous le souhaitez, le modifier ou le supprimer
Merci de me contacter par mail. Déclaré à la CNIL N°1031721.