Videos streaming images jeux et buzz
Connexion






Perdu le mot de passe ?

Inscrivez-vous maintenant !
Menu Principal
Communauté




CrazyCow
Excel 2016 : Comment faire varier la source d'un graphique ?
 1  #1
Je poste trop
Inscrit: 29/07/2008 00:26
Post(s): 12071
Karma: 12576
Hello !

J'ai besoin d'un coup de pouce de ceux qui connaissent bien Excel

Résultat souhaité :


J'ai un graphique en secteurs (camembert) qui utilise les données d'un tableau de ce type :

   A       B      C      D      E
Vente   | 2015 | 2016 | 2017 | 2018
Lieu A  |  23  |  25  |  22  |  27
Lieu B  |  35  |  30  |  29  |  25
Lieu C  |  13  |  15  |  16  |  18


Mon graphique est tout simple :

=SERIE(;A2:A4;B2:B4;1)


J'aimerais pouvoir changer la colonne utilisée pour le graphique (B dans ma formule ici) en fonction de la valeur en A10.

En A10, il y a un nombre entier entre 1 et 4. Si l'on saisie 2, j'aimerais que le graphique utilise la colonne C, donc l'équivalent de :

=SERIE(;A2:A4;C2:C4;1)


Je connais la fonction DECALER(), mais elle ne permet de décaler la référence d'une seule cellule uniquement.

Est-ce que vous avez une idée ou des pistes pour la formule à utiliser ?

Merci infiniment !

Contribution le : 27/04/2018 15:44
_________________
Je crois que je vais faire une vidéo qui montre comment manger un kiwi...
...plume par plume
Signaler

Kayron
 1  #2
Je masterise !
Inscrit: 06/09/2004 18:20
Post(s): 2032
Karma: 238
J'ai peut-être une solution un peu barbare:

Tu ajoutes une colonne masqué qui te servira de base de données pour ton graphique (ensuite tu peux masquer cette colonne)

Pour chaque case de cette colonne, tu donne la formule suivante:

=SI(A10=1;B3;SI(A10=2;C3;SI(A10=3;D3;SI(A10=4;E3;0))))






En gros, si la case A10 vaut 2, la colonne F sort le chiffre de la colonne C, si A10 vaut 4, la colonne F sort le chiffre de la colonne E etc

Contribution le : 27/04/2018 15:59
_________________
Je suis
Signaler

CrazyCow
 0  #3
Je poste trop
Inscrit: 29/07/2008 00:26
Post(s): 12071
Karma: 12576
@Kayron

Pas bête !

C'est vrai que dans mon cas je peux faire une colonne supplémentaire qui n'est pas visible ça ne me dérange pas.

Dans ce cas, une formule un peu plus élégante peut être la suivante

=DECALER(A2;0;A$10)




(J'aurais pu vous mettre à disposition mon fichier d'exemple, ça aurait été plus pratique...)

Contribution le : 27/04/2018 16:07
_________________
Je crois que je vais faire une vidéo qui montre comment manger un kiwi...
...plume par plume
Signaler

Kayron
 1  #4
Je masterise !
Inscrit: 06/09/2004 18:20
Post(s): 2032
Karma: 238
Citation :

@CrazyCow a écrit:

Dans ce cas, une formule un peu plus élégante peut être la suivante

=DECALER(A2;0;A$10)



C'est pour ça que j'ai dis "un peu barbare"...

Je ne connaissais pas la formule décaler, mais c'est complètement l'idée.

Contribution le : 27/04/2018 16:19
_________________
Je suis
Signaler


 Haut   Précédent   Suivant






Si vous êtes l'auteur d'un élément de ce site, vous pouvez si vous le souhaitez, le modifier ou le supprimer
Merci de me contacter par mail. Déclaré à la CNIL N°1031721.