Videos streaming images jeux et buzz
Connexion






Perdu le mot de passe ?

Inscrivez-vous maintenant !
Menu Principal
Communauté




cmer81
Erreur 404
 3  #1
Je viens d'arriver
Inscrit: 14/03/2017 20:14
Post(s): 7
Bonjour,

Il m'arrive assez souvent de ne plus pouvoir naviguer sur le site, chaque page me retourne une erreur 404..
La solution est d'effacer mes cookies ou bien de naviguer en mode privé.

Cela arrive le plus souvent quand c'est le serveur 62.210.201.242 qui me délivre la contenue.



Mes infos sur mon OS et le browser sont les suivantes




Merci d'avance 🙂

Contribution le : 26/12/2018 21:18
Signaler

Koreus
 0  #2
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 59597
Karma: 21322
Salut @cmer81

Alors c'est tout à fait normal que tu aies des erreurs 404 quand le serveur est 62.210.201.242
Car ce serveur n'héberge que les vidéos et pas de page web.

Ce qui n'est pas normal c'est que www.koreus.com pointe sur ce serveur, il devrait pointer sur 5.39.70.224
Donc il y a un problème de DNS quelque part.

La prochaine fois que cela se produit, il faudrait que tu fasses un "dig www.koreus.com" dans le terminal  et que tu copies colles la réponse pour savoir quel serveur DNS te donne la mauvaise info.

Contribution le : 26/12/2018 21:59
_________________
Signaler

cmer81
 0  #3
Je viens d'arriver
Inscrit: 14/03/2017 20:14
Post(s): 7
@Koreus Merci pour ta réponse !!

Je viens de mettre en place une sonde DNS qui effectue des checks depuis Paris, Amsterdam et Francfort si cela retourne autre chose que 5.39.70.224 pour le domaine www.koreus.com je devrais être averti.

A suivre donc...

Contribution le : 27/12/2018 00:40
Signaler

Bhaalil
 0  #4
Je suis accro
Inscrit: 05/02/2014 16:24
Post(s): 506
Karma: 271
J'ai exactement les mêmes problèmes sous Debian Stretch et Firefox (et même carte graphique, mais ça m'étonnerai que ça joue )

Il faut que je relance Firefox pour les résoudre.

Je vais enquêter aussi de mon côté.

Contribution le : 27/12/2018 00:50
Signaler

Koreus
 0  #5
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 59597
Karma: 21322
Pour info, c’est embed.koreus.com qui pointe sur 62.210.201.242

Contribution le : 27/12/2018 09:52
_________________
Signaler

cmer81
 0  #6
Je viens d'arriver
Inscrit: 14/03/2017 20:14
Post(s): 7
Hello,

Je viens d'avoir à nouveau le problème 🙂




Concernant le DNS, sur les 7 derniers jours, il y a des erreurs seulement depuis les résolutions depuis Paris sur les serveurs:

- dns200.anycast.me
- ns200.anycast.me


Contribution le : 05/01 13:02:41
Signaler

Koreus
 0  #7
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 59597
Karma: 21322
Je ne vois pas d'où cela peut venir, car de mon côté tout est bien configuré.
Pour évaluer l'étendu du problème et pour avertir les visiteurs, j'ai ajouté une page d'explication si on est victime de ce problème DNS ( au lieu d'avoir une erreur 404)

Contribution le : 17/01 16:06:30
_________________
Signaler

Erdinger
 0  #8
Je viens d'arriver
Inscrit: 24/05/2009 01:06
Post(s): 30
Karma: 72
J'ai souvent eu des erreurs 404 moi aussi (je suis sur Ubuntu 16.04 et Firefox 64.0).

Maintenant du coup je vois la page d'explication mise en place par @Koreus...

Quelques explications qui pourraient peut-être vous aider à résoudre le problème:

- dig koreus.com me donne bien la bonne adresse (5.39.70.224)
- le problème apparaît généralement après avoir visionné quelques vidéos, mais jamais à la première
- le problème n'apparaît jamais sur Google Chrome

Contribution le : 17/01 21:39:11
Signaler

Koreus
 0  #9
Webhamster
Inscrit: 03/07/2002 23:58
Post(s): 59597
Karma: 21322
Merci pour ce retour.
Firefox le problème ? Bizarre...

Je vais activer les logs sur le « mauvais server » pour voir si cela concerne uniquement Firefox ou d’autres navigateurs

Contribution le : 17/01 23:03:40
_________________
Signaler

NeoMacFly
 0  #10
Je viens d'arriver
Inscrit: 30/01 21:55:11
Post(s): 1
Hello,

je viens d'avoir aussi ce probleme,
les DIG dans tout les sens sur plein de serveurs différent et sur mon PC, bien sur, mais répond la bonne IP !

si tu as récupérer les logs sur le "mauvais serveur" et que cela n'impacte que les firefox, c'est peut etre lié au
TRR*/DOH* une fonction qui utilise les DNS CloudFare au lieu du DNS local !

peut être que celui la merde à un moment ou un autre?
ou firefox lui meme ?

j'ai fait des test dessus aussi mais cela repond la bonne IP aussi
(curl -s -H 'accept: application/dns-json' 'hxxps://mozilla.cloudflare-dns.com/dns-query?name=koreus.com&type=A')

NeoMacFly

*Trusted Recursive Resolver
*DNS Over HTTP

Firefox 64.0.2 (64Bits) on Windows 10

Contribution le : 30/01 22:03:33
Signaler

gonorrhus
 0  #11
Je m'installe
Inscrit: 04/01/2017 19:08
Post(s): 403
Karma: 170
Même soucis pour moi. J'ai cru un instant que c'était un ban caché (je compisse les gilets jaunes - avec raison - un peu trop souvent au goût de certains). J'ai eu peur.

Mes observations:
1) les requêtes DNS de Firefox, capturées avec Wireshark, retournent la bonne IP,

2) la requête de Firefox pour ouvrir la page semble correcte, mais vu que je ne suis plus très habitué à Wireshark (je l'utilisais quand Facebook n'était pas encore en https), je n'ai pas vérifié depuis Wireshark si Firefox a fait toc-toc à la bonne porte

3) la commande cUrl de cette requête (Firefox le propose amicalement), y-compris avec les cookies, fonctionne parfaitement

4) supprimer les cookies a résolu le problème et m'empêche de fouiller plus profondément (petite pensée pour quelqu'un) pour le moment

Je me demande s'il n'y a pas du cache impliqué ... et que la suppression des cookies implique une remise à zéro de ce cache.

Question bête : c'est pas possible de remplacer le 404 par un 301 ?

Contribution le : 20/03 23:55:15
Signaler

trachsel
 0  #12
Je m'installe
Inscrit: 23/08/2018 00:36
Post(s): 171
Karma: 93

Contribution le : 21/03 10:24:50
Signaler

gonorrhus
 0  #13
Je m'installe
Inscrit: 04/01/2017 19:08
Post(s): 403
Karma: 170
C'est intéressant. Le problème est revenu. J'ai fait un petit

find . | while read F ; do grep -als 'koreus' "$F" ; done | while read G ; do echo "$G" ; sed -i 's/koreus/goreus/g' "$G" ; done


dans mon dossier de Firefox, et ça n'a rien résolu. Ca n'a rien cassé non plus. Par contre, en navigation privée, ça fonctionne bien. Est-ce que quelqu'un sait si Firefox utilise des données stockées hors de ~/.mozilla/firefox/profilefolder, mais n'y accède pas lors de la navigation privée ?

Contribution le : 09/04 10:57:00
Signaler

Erdinger
 0  #14
Je viens d'arriver
Inscrit: 24/05/2009 01:06
Post(s): 30
Karma: 72
@gonorrhus Le problème n'a jamais disparu chez moi, après avoir visionné environ 2 vidéos,  j'ai une mauvaise résolution DNS de Firefox...
Du coup je m'étais résigné à abandonner Firefox pour Chrome pour ce qui est de la navigation sur Koreus.

J'ai essayé de passer en navigation privée comme tu le proposais et effectivement, cela règle le problème mais seulement temporairement, le temps de regarder 2 nouvelles vidéos.... puis l'erreur revient.
On peut bien sûr rouvrir à chaque fois une nouvelle fenêtre privée à chaque nouveau bug mais c'est pénible.

Ca serait bien de trouver une solution.

------------------------------------

Edit:

J'ai peut-être une solution (côté client malheureusement):
Firefox garde en cache une partie des requêtes DNS, or, on peut fixer l'expiration de ce cache à 0 afin de le désactiver complètement. Il semblerait que cela fonctionne chez moi, à voir sur la durée.

Pour reproduire le fix:

ouvrir about :config (dans la barre de navigation de Firefox)
rechercher network.dnsCacheExpiration
changer la valeur par défaut à 0

Contribution le : 11/04 10:50:17
Signaler


 Haut   Précédent   Suivant






Si vous êtes l'auteur d'un élément de ce site, vous pouvez si vous le souhaitez, le modifier ou le supprimer
Merci de me contacter par mail. Déclaré à la CNIL N°1031721.